เว็บสำเร็จรูป เว็บสำเร็จรูปภาครัฐ เว็บโรงเรียน เว็บไซต์ส่วนตัว ระบบบริหารจัดการเว็บไซต์ (CMS) ฟรี

ขอถามเรื่อง iframe ครับ ใส่หน้าแรกแล้ว ข้อมูลเปลี่ยน แล้วแต่หน้า

ขอถามเรื่อง iframe ครับ ใส่หน้าแรกแล้ว ข้อมูลเปลี่ยน แล้วแต่หน้าเว็บไม่เปลี่ยนตาม

คือผมนำ iframe ไปใส่ใน Box รหัส html.....บันทึกโอเคดูหน้าเว็บปกติทุกอย่างไม่มีปัญหาอะไรทั้งนั้น



แต่พอ ในหน้าส่วนของ iframe มีการอัพเดทเช่น จาก 1 เป็น 2

ในหน้าเว็บก็ยัง 1 ไงงั้นกด F5 กี่รอบๆ ก็ ยังเป็น 1

ต้องเข้าลิ้งตรงจาก iframe แล้วมาเข้าหน้าเว็บแรก ถึงจะแสดงเป็น 2





ไม่ทราบพอมีทางแก้ไขไหมครับ
20 มิ.ย. 2554 8 2,268

ลองดูแล้วนะครับเป็นเฉพาะหน้าแรก โมดูลหน้าที่เราสร้างขึ้นมาเอง ข้อมูลอัพเดทเป็นปกติครับ ไม่เหมือนกับหน้าแรก
ความคิดเห็น #1 20 มิ.ย. 2554 183.89.xxx.xx

ใส่ได้แล้วมั้ง



อาจเป็นที่ cache นะครับ ต้องรอสัก 1 นาทีถึงจะเปลี่ยน (หรือตามที่กำหนด)



ปกติแล้วถ้าสามารถเขียนอย่างอื่นได้ iframe ก็สาารถเขียนได้ครับ ไม่เกี่ยวกับ GCMS แต่อย่างใด
ความคิดเห็น #2 20 มิ.ย. 2554 223.204.xxx.xxx

รอแล้วนะครับ - - แต่ก้อไม่อัพเดทให้อยู่ดี ต้อง reload จากช่อง iframe โดยตรง
ความคิดเห็น #3 20 มิ.ย. 2554 183.89.xxx.xx

อ้างอิงจาก ความคิดเห็น #3รอแล้วนะครับ - - แต่ก้อไม่อัพเดทให้อยู่ดี ต้อง reload จากช่อง iframe โดยตรง


อืม.. ผมก็เห็นกรอบ facebook และ กรอบ radio อยู่บนเว็บนะครับ
ความคิดเห็น #4 20 มิ.ย. 2554 223.204.xxx.xxx

อยากให้ อาจารลองสมัครครับ ครับแล้วดูตรง All id ในส่วนของหน้าแรกดูครับ ถ้าสมัคร มันจะ +1 เรื่อยๆ

แต่นี่กด F5 กี่ทีๆ ก้อไม่เพิ่มครับ แล้วอาจารลองคลิกขวา ที่ iframe ในส่วนของ all id ดู มันถึง จะเพิ่มครับ







หากพิมอะไรไม่เข้าใจต้องขออภัยครับ
ความคิดเห็น #5 20 มิ.ย. 2554 58.8.xx.xx

อ้างอิงจาก ความคิดเห็น #5อยากให้ อาจารลองสมัครครับ ครับแล้วดูตรง All id ในส่วนของหน้าแรกดูครับ ถ้าสมัคร มันจะ +1 เรื่อยๆ

แต่นี่กด F5 กี่ทีๆ ก้อไม่เพิ่มครับ แล้วอาจารลองคลิกขวา ที่ iframe ในส่วนของ all id ดู มันถึง จะเพิ่มครับ


55+++ คงไม่เกี่ยวอะไรกับ GCMS แล้วมั้งครับ เนื่องจาก หน้านั้นเป็น iframe ซึ่งไม่เกี่ยวข้องอะไรกับ GCMS (iframe ก็ต้องไปตรวจสอบการทำงานที่ iframe) ถ้ามันสามารถแสดง iframe ได้ ทุกอย่างก็คงถูกต้องแล้วละครับ การแก้ไขก็คงต้องไปตรวจสอบที่ โค้ดใน iframe แทน



ที่เป็นไปได้ อาจเป็นที่ cache ของ Browser ครับ ลองกำหนดให้หน้า iframe ไม่เอาจาก cache ดูครับ อาจช่วยได้ (ลองหาอ่านบทความบนเว็บดู)
ความคิดเห็น #6 20 มิ.ย. 2554 223.204.xxx.xxx

โอเคเทสละครับ สรุปเป็นเฉพาะ google chorme
ความคิดเห็น #7 20 มิ.ย. 2554 183.89.xxx.xx

ได้ละครับ ยัด

header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1 

header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Date in the past 

ลงไปใน iframe เพื่อใครเป็นเหมือนกัน - -"
ความคิดเห็น #8 20 มิ.ย. 2554 183.89.xxx.xx
ความคิดเห็น
ไฟล์อัปโหลด ชนิด jpg, jpeg, gif, png ขนาดไฟล์ไม่เกิน 1024
^