เว็บสำเร็จรูป เว็บสำเร็จรูปภาครัฐ เว็บโรงเรียน เว็บไซต์ส่วนตัว ระบบบริหารจัดการเว็บไซต์ (CMS) ฟรี

แจ้งปัญหาการติดตั้ง และ ใช้งาน GCMS 4.5.0 ได้ที่นี่เลยครับ

รบกวนใครมีปัญหา หรือข้อเสนอแนะ สามารถแจ้งได้ที่กระทู้นี้เลยครับ
07 เม.ย. 2554 23 2,647

สวัสดีครับ



หลังจากการอัพเกรด เวอร์ชั่น 4.5.0 แล้ว (ผมอัพเกรดจากเวอร์ชั่นเดิมครับ)



พบปัญหาดังนี้ครับ



1. เมื่อ login จากหน้าเว็บปกติ จะขึ้นดังรูปด้านล่าง ทำให้เข้าระบบไม่ได้

error ที่เกิดขึ้น





2. เข้าระบบ admin (www.domain.com/admin/) ได้ แต่ สถานะของ user admin เป็น mod,  หากมีการ ปรับเป็น admin และ ทำการ logout แล้วลอง login เข้าใหม่ จะไม่สามารถ login ได้ ต้องไปปรับ status ใน database เป็น 1 ก่อน

และเมื่อ login เข้ามา สถานะ admin ก็จะเป็นแค่  mod เหมือนเดิมครับ



3. error หน้าแรก หากมีการ login ค้างอยู่ (admin login)

gcms error 2



ตอนนี้ พบปัญหาอยู่ประมาณนี้ครับ

ขอบคุณครับ
ความคิดเห็น #1 08 เม.ย. 2554 58.8.xx.xxx

555+++



ปัญหาเกิดขึ้นเพราะไม่ได้ทำตามขั้นตอนการ อัปเกรดที่ถูกต้องนะครับ



1.จะต้องแก้ไขสถานะของสมาชิกก่อนด้วยการลบ สถานะของสมาชิก ให้เหลือแค่ สมาชิกทั่วไปและ แอดมิน ในกรณีที่ไม่ได้ทำ ให้เข้าไปแก้ไขสถานะของสมาชิกด้วยตัวเองที่ฐานข้อมูลครับ โดยการเข้าไปแก้ไขฟิลด์ status ของรายชื่อคนที่เป็นแอดมิน ให้เท่ากับ 1 (สมาชิกทั่วไปเป็น 0)

2.error ที่บรรทัด 115 น่าจะเป็นเพราะไม่มีข้อมูลนี้ $config['admin_access'] = array(1); ให้เขียนตัวแปรนี้ ใส่ไว้ใน bin/config.php ด้วยครับ

โดยปกติแล้ว หลังจากแก้ไข ตามข้อ 1 และ เข้าระบบแอดมินได้ ให้เข้าไปแก้ไข config ของระบบก่อน โดยเข้าไปที่เมนู กำหนดค่าไซต์ ต่างๆ แล้วทำการบันทึกค่าในแต่ละหน้าของเมนูนั้นเพื่อให้ระบบจัดการ config ต่างๆที่ถูกต้องให้ (โดยเฉพาะหน้า กำหนดค่าไซต์=>ทั่วไป) ซึ่งจะมีส่วนจัดการเกี่ยวกับ config ที่สำคัญ หรืออาจแก้ไขไฟล์ config.php โดยตรงได้โดยดูจาก default.config.php ของเวอร์ชั่นใหม่ครับ





ความคิดเห็น #2 08 เม.ย. 2554 183.88.xx.xxx

สวัสดีครับ



ออ ผมอ่านไม่เคลียร์นี่เอง



คือผม  เข้าใจว่า ให้เข้าไปปรับแก้สถานะ ของ สมาชิก ให้เหลือไว้แค่ admin กับ สมาชิกทั่วไป (โดยแก้ผ่านเมนุผู้ใช้)



$config['admin_access'] = array('1', '2');



ใน ไฟล์ config.php ผม เป็น แบบนี้ครับ  ผมต้องตัดเอา  2 ออกไปมั้ยครับ? หรือคงค่าไว้อย่างเดิมครับ



ได้ ลอง ปรับแก้ตามที่พี่บอกแล้ว

สำหรับ error ที่หน้าแรก ตอนนี้ ไม่มีแล้วครับ



และ สถานะ user ตอนนี้ได้ปรับแก้เรียบร้อยแล้วครับ



ขอบคุณพี่มากๆ นะครับ
ความคิดเห็น #3 08 เม.ย. 2554 58.8.xx.xxx

admin_access คือ สถานะของสมาชิกที่สามารถเข้าระบบแอดมินได้ครับ ตามที่กำหนดเป็นค่า default ไว้คือ สถานะ 1 และ 2



1 จะเป็นแอดมินระดับสูงสุดครับ (ไม่เหมือนเวอร์ชั่นก่อนนะครับ)

0 เป็นสมาชิกทั่วไป

ทั้งสองค่า จะเป็นสถานะปกติของระบบ ซึ่งจะเป็นไปโดยอัตโนมัติ ส่วนระดับอื่นๆ สามารถสร้างได้ไม่จำกัด เช่น 2 อาจกำหนดให้เป็น ผู้ช่วยแอดมิน (ซึ่งค่าปกติกำหนดไว้แบบนี้)



ค่าต่างๆ ทั้งหมดที่เกี่ยวข้องในไฟล์ config สามารถแก้ไขได้จากระบบนะครับ ไม่จำเป็นต้องแก้ไขเอง (หากเข้าแอดมินได้ และเห็นเมนูตั้งค่า) การแก้ไขค่าต่างๆสามารถทำได้โดยการ Save ค่ากำหนดในหน้าต่างๆ ซึ่งระบบจะทำการแก้ไขไฟล์ใหม่ให้ครับ



ความคิดเห็น #4 08 เม.ย. 2554 183.88.xx.xxx

ถ้าอัพเกรดจาก 4.4.0 เป็น 4.5.0 ต้องเปลี่ยนอะไรเยอะไหมครับ หรือทำตามขั้นตอนได้เลย...
ความคิดเห็น #5 11 เม.ย. 2554 124.120.xxx.xxx


Cache directory is not permission





เป็นเพราะอะไรครับ
ความคิดเห็น #6 11 เม.ย. 2554 223.205.xxx.xxx

อ้างอิงจาก ความคิดเห็น #5ถ้าอัพเกรดจาก 4.4.0 เป็น 4.5.0 ต้องเปลี่ยนอะไรเยอะไหมครับ หรือทำตามขั้นตอนได้เลย...
ถ้าไม่ได้ดัดแปลงอะไร ทำตามขั้นตอนที่ผมกำหนดได้เลยครับ

อ้างอิงจาก ความคิดเห็น #6

Cache directory is not permission





เป็นเพราะอะไรครับ


ไม่สามารถสร้าง directory cache ได้ครับ ลองพยายามปรับ chmod ให้ direcotry datas/ และโฟลเดอร์ทั้งหมดให้เป็น 646 หรือถ้าจำเป็นให้ใช้ 777 ครับ
ความคิดเห็น #7 15 เม.ย. 2554 182.52.xxx.xxx


ของผมขึ้น แบบนี้ครับ Error in : function mysql_connect Message : Error in : SELECT M.`module`,M.`owner`,M.`parent`,I.`menu_text`,I.`menu_order`,I.`menu_tooltip`,M.`menu_target`,M.`menu_url`,(CASE M.`parent` WHEN 'MAINMENU' THEN 0 WHEN 'BOTTOMMENU' THEN 1 WHEN 'SIDEMENU' THEN 2 ELSE 3 END ) AS `pos` FROM `png_index` AS I,`png_modules` AS M WHERE((M.`module`='' AND M.`owner`='index') OR I.`menu_text`<>'') AND M.`id`=I.`module_id` AND I.`language`IN('th','') ORDER BY `pos` ASC, I.`menu_order`DESC Message : Error in : SELECT * FROM `png_user` WHERE `username`='admin' LIMIT 1; Message : Error in : SELECT * FROM `png_counter` ORDER BY `id` DESC LIMIT 1 Message : Error in : INSERT INTO `png_counter` (`visited`,`pages_view`,`date`,`counter`,`time`) VALUES ('1','1','2011-04-15','1','1302869678'); Message : Error in : SELECT M.`id`,M.`module`,I.`topic`,I.`detail`,I.`keyword`,I.`description`,I.`menu_text`,I.`menu_tooltip`,M.`config`,(SELECT COUNT(*) FROM `png_category` WHERE `module_id`=M.`id`) AS `categories`FROM `png_index` AS I,`png_modules` AS M WHERE I.`menu_text`<>'' AND M.`module`='board' AND I.`module_id`=M.`id` AND I.`language` IN('th', '') LIMIT 1 Message :

ผมลงใหม่ทั้งหมดครับตอนที่ลงก็ใช้ได้แต่อีกวันกลับขึ้นมาแบบนี้อะครับ


ความคิดเห็น #8 15 เม.ย. 2554 14.207.xxx.xxx

สวัสดีครับ



ผมมีข้อสอบถามเพิ่มเติมครับ



คือ ตรง share ของ facebook กับ twitter อ่ะครับ



ผมทำการ login เรียบร้อย แล้วลอง กด share ของ facebook เพื่อที่จะทำการ share ก็ขึ้นข้อมูลปกติ (ดังรูป)







แต่พอกดที่ share จะขึ้น error ดังรูปด้านล่าง







ไม่ทราบว่าเป็นเพราะอะไรหรือครับ หรือผมต้อง setting ค่าอะไรเพิ่มเติมหรือเปล่าครับ



รบกวนขอคำแนะนำด้วยนะครับ

ขอบคุณครับ
ความคิดเห็น #9 18 เม.ย. 2554 58.8.xxx.xxx

อ้างอิงจาก ความคิดเห็น #8


ของผมขึ้น แบบนี้ครับ Error in : function mysql_connect Message : Error in : SELECT M.`module`,M.`owner`,M.`parent`,I.`menu_text`,I.`menu_order`,I.`menu_tooltip`,M.`menu_target`,M.`menu_url`,(CASE M.`parent` WHEN 'MAINMENU' THEN 0 WHEN 'BOTTOMMENU' THEN 1 WHEN 'SIDEMENU' THEN 2 ELSE 3 END ) AS `pos` FROM `png_index` AS I,`png_modules` AS M WHERE((M.`module`='' AND M.`owner`='index') OR I.`menu_text`<>'') AND M.`id`=I.`module_id` AND I.`language`IN('th','') ORDER BY `pos` ASC, I.`menu_order`DESC Message : Error in : SELECT * FROM `png_user` WHERE `username`='admin' LIMIT 1; Message : Error in : SELECT * FROM `png_counter` ORDER BY `id` DESC LIMIT 1 Message : Error in : INSERT INTO `png_counter` (`visited`,`pages_view`,`date`,`counter`,`time`) VALUES ('1','1','2011-04-15','1','1302869678'); Message : Error in : SELECT M.`id`,M.`module`,I.`topic`,I.`detail`,I.`keyword`,I.`description`,I.`menu_text`,I.`menu_tooltip`,M.`config`,(SELECT COUNT(*) FROM `png_category` WHERE `module_id`=M.`id`) AS `categories`FROM `png_index` AS I,`png_modules` AS M WHERE I.`menu_text`<>'' AND M.`module`='board' AND I.`module_id`=M.`id` AND I.`language` IN('th', '') LIMIT 1 Message :

ผมลงใหม่ทั้งหมดครับตอนที่ลงก็ใช้ได้แต่อีกวันกลับขึ้นมาแบบนี้อะครับ


ปัญหาเกิดจาก error แรกเลยครับ Error in : function mysql_connect เดาว่า username+password ผิด ซึ่งอาจเป็นไปได้ว่า username หรือ password อาจเป็นตัวเลขทั้งหมด ให้แก้ไข bin/config.php ให้เป็นค่าที่ถูกต้องด้วยตัวเองครับ
ความคิดเห็น #10 20 เม.ย. 2554 183.88.xx.xxx

อ้างอิงจาก ความคิดเห็น #9สวัสดีครับ



ผมมีข้อสอบถามเพิ่มเติมครับ



คือ ตรง share ของ facebook กับ twitter อ่ะครับ



ผมทำการ login เรียบร้อย แล้วลอง กด share ของ facebook เพื่อที่จะทำการ share ก็ขึ้นข้อมูลปกติ (ดังรูป)







แต่พอกดที่ share จะขึ้น error ดังรูปด้านล่าง







ไม่ทราบว่าเป็นเพราะอะไรหรือครับ หรือผมต้อง setting ค่าอะไรเพิ่มเติมหรือเปล่าครับ



รบกวนขอคำแนะนำด้วยนะครับ

ขอบคุณครับ


ผมก็ไม่ได้เซ็ตอะไรเพิ่มเติมนะครับ สามารถโพสต์ได้
ความคิดเห็น #11 20 เม.ย. 2554 183.88.xx.xxx

สวัสดีครับ



คือ ผมก็ไม่ได้ set อะไรเพิ่มเติมเลยครับ



ลองของเว็บพี่ ได้



แต่พอกลับมาลองที่เว็บผมเอง มันกลับไม่ได้เฉยเลยครับ



ยัง งงๆ อยู่
ความคิดเห็น #12 21 เม.ย. 2554 58.11.xx.xxx

อัพโหลดไฟล์ผ่าน ckeditor ไม่ได้ค่ะ

ไม่แน่ใจว่าต้องไป CHMOD ตรงโฟลเดอร์ไหนหรือเปล่า

แต่ตอนนี้อัพโหลดไม่ได้ค่ะ พอกดบราวซ์ มันจะขึ้นเป็น 404 Forbidden ค่ะ

ตอนนี้เลยต้องใช้วิธีแทรก url เอา



และที่เว็บตอนนี้ฟังก์ชั่น zoom ใช้ไม่ได้ค่ะ

(http://www.pasrasaa.com/home/faqwriter.html)

รูปไม่ยอมย่อขนาดเลย



การแทรก Widget ลงส่วนต่างๆ ของเว็บก็ใช้ไม่ได้ค่ะ

พอเอาโค้ดไปวางในส่วน html ของ ckeditor มันก็จะขึ้นเป็นข้อความนั้นๆ ไม่ได้ขึ้นเป็น Widget




อีกอย่างหนึ่งค่ะ ไม่มีรูป new ขึ้นหลังกระทู้ค่ะ ต้องแก้ไขตรงไหนคะ

ขอคำแนะนำด้วยค่ะ



ส่วนที่อยากเสนอ คือการกำหนดเมนูน่ะค่ะ

อยากให้มีการกำหนดสิทธิด้วยเลย เช่น หน้านี้ต้องเป็นสมาชิกเท่านั้น

หรือหน้านี้้ต้องเป็นสมาชิกกลุ่มนี้เท่านั้นถึงจะเปิดเข้าดูได้ค่ะ


ความคิดเห็น #13 22 เม.ย. 2554 110.169.xxx.xx

1.การอัปโหลดรูปภาพผ่าน CKEDITOR ต้องการโฟลเดอร์ datas/image/ ครับ ถ้าไม่มีให้สร้างใหม่ หรือถ้ามีแล้วให้ปรับ chmod เป็น 777 ครับ



2.zoom จะทำงานอัตโนมัติ เมื่อมีการปรับขนาดรูปภาพเท่านั้นนะครับ ถ้ารูปที่แสดงอยู่เป็นขนาดจริง zoom จะไม่ทำงาน



3.การติดตั้ง widget ต้องอยู่ภายใต้ แบบนี้เท่านั้นนะครับ ถ้าไม่สามารถแทรกได้ ให้ลองแทรกโดยใช้โหมด HTML (คลิก ดูรหัส HTML ที่เมนูของ CKEDITOR)



4.เครื่องหมาย new และ อัปเดทที่กระทู้ของบอร์ด ให้แทรกโค้ดนี้ที่ style.css ครับ



dl.board-listitem a.new {

    background: url(img/new.gif) right center no-repeat;

}

dl.board-listitem a.update {

    background: url(img/update.gif) right center no-repeat;

}



รูปภาพ new.gif และ update.gif ถ้าไม่มีหามาใส่เองได้เลยนะครับ โดยอัปโหลดไว้ที่ img/ ครับ
ความคิดเห็น #14 22 เม.ย. 2554 223.204.xxx.xxx

1. โฟลเดอร์ที่ว่าอยู่ที่ root เลยใช่ไหมคะ ทำแล้วเรียบร้อย ปรับเป็น 777 เรียบร้อยแต่ก็ยังเป็น 404 เหมือนเดิมค่ะ ในโฟลเดอร์เห็นภาพที่อัพทำ BG อยู่ในนั้นด้วยค่ะ ไม่แน่ใจว่าใช่โฟลเดอร์เดียวกันหรือเปล่า :39:





2. ฟังก์ัชั่น zoom นี่จะใช้ได้ผลกับรูปที่อัพผ่าน ckeditor เท่านั้นหรือเปล่าคะ เพราะลองปรับขนาดแล้ว แต่ก็ยังเหมือนเดิมค่ะ (หรือว่าต้องเป็นรูปที่ถูกย่อโดยระบบ)
ตามลิงก์นี้





3. ไม่ขึ้นค่ะ ตามลิงก์นี้





4. ลิงก์ในข้อสาม จะเห็นได้ว่า รูปขึ้นแต่ update ค่ะ แต่ new ไม่ขึ้น (ตอนนี้ปรับกระทู้ใหม่ให้อยู่ที่ 10 วันค่ะ)





รบกวนด้วยนะคะ อาจจะต้องกวนเยอะหน่อย เพราะมีความรู้ทางด้านนี้งูๆ ปลาๆ มากค่ะ blush

ขอบคุณสำหรับคำตอบค่ะ
ความคิดเห็น #15 22 เม.ย. 2554 124.121.xx.xxx

1. ใช่ครับ ปกติโฟลเดอร์เหล่านี้จะถูกสร้าง และ ปรับ chmod อย่างถูกต้องตอน install แต่มันก็สามารถสร้างเองได้ หาก CKEDITOR ต้องการใช้งานนะครับ ดังนั้นถ้า chmod ที่โฟลเดอร์ datas/ ถูกต้อง คงไม่มีปัญหาส่วนนี้

ในกรณีที่พบว่ามีโฟลเดอร์ แต่ระบบไม่แสดงรูปภาพ อาจมีปัญหาที่ค่ากำหนดของ Server เองครับ (ไม่สามารถใช้ความสามารถบางรายการได้) คำแนะนำคือ ถ้าไม่ลำบากนัก รบกวนส่ง username+password ของ ftp ให้ผม เพื่อผมจะได้ตรวจสอบกับ Server ได้โดยตรง



2.ที่ zoom ไม่ทำงานอาจเป็นเพราะ ข้อผิดพลาดของ Javascript นะครับ เนื่องจากพบว่าบนเว็บมี Error อยู่ โอกาศที่เป็นไปได้คือ ผมเห็นมีการติดตั้งโค้ด google analytics อยู่ ซึ่งเขียนไม่ถูกต้องครับ ให้นำโค้ดนี้ไปไว้ล่างสุดของเว็บ ภายใต้ body เลยครับ



3.widget บางรายการ จะไม่แสดงในบางตำแหน่งนะครับ เนื่องจาก widget จะใช้ javascript การมี javascript ซ้ำซ้อนอาจมีปัญหาการใช้งานได้ ในกรณีของ widget search มันถูกออกแบบให้ทำงานกับทุกโมดูลครับ ดังนั้นการเอาไว้ที่ sidebar จะถูกต้องแล้ว และ จะไม่สามารถแทรกในหน้า board ได้ครับ



4. กระทู้ pin และ locked จะไม่แสดงไอคอน new และ update ในหน้านี้นะครับ เนื่องจาก pin มันจะแสดงเสมอ ผมก็เลยเดาว่ามันไม่จำเป็น (ความเห็นส่วนตัว ถ้าจะแก้ไขต้องแก้ไขโค้ด modules/board/stories.php บรรทัดที่ 117 ครับ) ส่วน locked มันคงไม่มีโอกาศอัปเดทหรอกครับ...






ความคิดเห็น #16 22 เม.ย. 2554 223.204.xxx.xxx

1. เดี๋ยวส่งให้ทางอีเมล์นะคะ



2. ลองเอา google analytics ออกแล้ว ยังคงซูมไม่ได้ค่ะ



3. และ 4. รับทราบค่ะ ^^



ขอบคุณสำหรับคำตอบนะคะ
ความคิดเห็น #17 22 เม.ย. 2554 124.121.xx.xxx

มีเรื่องมารบกวนอีกแล้วค่ะ

ในส่วนของบทความ พอใช้ rss เรียกมาแสดงหน้าเว็บ

รูปภาพไม่ตามมาด้วยค่ะ

ไม่ทราบว่าต้องไปกำหนดตรงไหนยังไงหรือเปล่าคะ
ความคิดเห็น #18 26 เม.ย. 2554 110.169.xxx.xxx

อ้างอิงจาก ความคิดเห็น #18มีเรื่องมารบกวนอีกแล้วค่ะ

ในส่วนของบทความ พอใช้ rss เรียกมาแสดงหน้าเว็บ

รูปภาพไม่ตามมาด้วยค่ะ

ไม่ทราบว่าต้องไปกำหนดตรงไหนยังไงหรือเปล่าคะ






แก้ปัญหาได้แล้วค่ะ ดู widget ไม่ดีเอง ><
ความคิดเห็น #19 26 เม.ย. 2554 124.121.xx.xx

ทำไม v.4.5 rss รูปไม่ขึ้น (rsstab)
ความคิดเห็น #20 09 พ.ค. 2554 58.10.xxx.xxx

แจ้งปัญหาการติดตั้ง และ ใช้งาน GCMS 4.5.0 ได้ที่นี่เลยครับ


วันนี้อยู่ๆ เว็บก็แสดงผลออกมาแบบ นี้อะครับ


ความคิดเห็น #21 12 พ.ค. 2554 202.176.xx.xxx

ย้าย Server หรือเปล่าเอ่ย ลอง viewsource ดู path มันไม่ถูกต้อง



ที่ตัวแปร ROOT_PATH ใน bin/vars.php ถ้าแก้ปัญหาไม่ได้ ให้กำหนดค่านี้ด้วยตัวเอง (ปัจจุบันโปรแกรมตรวจสอบให้)



หรือลองอัปเกรดเป็น 4.5.1 (ล่าสุด)



ความคิดเห็น #22 12 พ.ค. 2554 223.205.xxx.xxx


ไม่ได้มีการเปลี่ยนเปลงอะไรครับจู่ๆก็ไปเลย เดี่ยวจะลองอัปเกรดดูครับ ขอบคุณครับ


ความคิดเห็น #23 12 พ.ค. 2554 202.176.xx.xxx
ความคิดเห็น
ไฟล์อัปโหลด ชนิด jpg, jpeg, gif, png ขนาดไฟล์ไม่เกิน 1024
^